Back to overview
Resolved

Some services are down

May 22, 2026 at 4:10pm UTC
Affected services
Cloud BGP Router

Resolved
May 22, 2026 at 4:10pm UTC

We are writing to provide you with a critical update regarding a major security and technical incident that has impacted our network.

Over the past few days, our network was targeted by a massive, sophisticated Distributed Denial of Service (DDoS) attack. The sheer volume and nature of this attack led to severe network instability, which unfortunately resulted in catastrophic data corruption and the permanent loss of underlying infrastructure across several key regions.

Despite the exhaustive efforts of our engineering and incident response teams to mitigate the traffic and preserve data integrity, the infrastructure in the following regions was permanently damaged and cannot be restored:

United States
Germany
The Netherlands
Austria
Canada
Because the attack caused hardware-level failures and corrupted file systems beyond recovery, all hosted data and servers within these specific zones are no longer accessible.

We know how critical your workloads are, and our teams have been working around the clock to isolate the impact, stabilize our core internal systems, and deploy clean infrastructure.